Elevated latency in services (Vercel dashboard, API, v0)

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 19:07 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 28, 2025 - 18:58 UTC

Monitoring

The build queues are being processed and we're continuing to monitor the services.
Posted Feb 28, 2025 - 18:22 UTC

Identified

Customers are currently experiencing elevated latency while accessing the Vercel dashboard, using the API or creating new prompts on v0. New builds are currently being queued and Log Drains are delayed.
Posted Feb 28, 2025 - 18:09 UTC

Update

The build queues are being processed and we're continuing to monitor the service.
Posted Feb 28, 2025 - 18:00 UTC

Update

Most services have recovered, and we're actively working on clearing the queued builds.
Posted Feb 28, 2025 - 17:20 UTC

Monitoring

We have implemented a fix and are currently monitoring the service.
Posted Feb 28, 2025 - 17:04 UTC

Update

We are continuing to investigate. For urgent deployments, the Vercel CLI is unaffected and can be used. https://vercel.com/docs/cli
Posted Feb 28, 2025 - 16:41 UTC

Update

We're seeing recovery, but some services may still be partially degraded. We’re continuing to work on the mitigation.
Posted Feb 28, 2025 - 16:16 UTC

Identified

We have identified the issue and working on a fix. Customer websites remain unaffected.
Posted Feb 28, 2025 - 15:55 UTC

Update

We are continuing to investigate this issue.
Posted Feb 28, 2025 - 15:35 UTC

Investigating

Customers are currently experiencing elevated latency while accessing the Vercel dashboard, using the API or creating new prompts on v0. New builds are currently being queued and Log Drains are delayed.
Posted Feb 28, 2025 - 15:27 UTC
This incident affected: API, Log Drains, Dashboard (Dashboard, Support Center), and Build & Deploy (Builds).