Reports of queued builds

Incident Report for Vercel

Resolved

The incident has been resolved. We are still monitoring the status of our build's systems, and related services, closely.
Posted Jul 04, 2025 - 16:30 UTC

Monitoring

The issue has been identified and resolved, and we're actively monitoring build infrastructure and dependent services.
Posted Jul 04, 2025 - 16:19 UTC

Identified

We have identified the issue, and our engineers are working on a fix.
Posted Jul 04, 2025 - 16:01 UTC

Investigating

We are investigating reports of deployments in the "queued" state for new builds. Live traffic is not affected by this issue.
Posted Jul 04, 2025 - 15:49 UTC
This incident affected: Build & Deploy (Builds).