DNS Verification Issue

Incident Report for Vercel

Resolved

All domain verification functionality has been restored.
Posted May 16, 2025 - 19:57 UTC

Identified

We have identified the cause of this incident and are working on a fix. Scope of impact is limited to domains that are in a configured DNS record set but not yet verified.
Posted May 16, 2025 - 18:16 UTC

Investigating

We are investigating errors in our DNS configuration UI. It is occasionally showing your existing DNS records instead of the records you should be setting.

You may still configure a domain manually:
- For apex domains, set an A record to 76.76.21.21
- For subdomains, set a CNAME record to cname.vercel-dns.com
Posted May 16, 2025 - 17:53 UTC
This incident affected: DNS.