Delayed SSL Certificate Issuance/Update by Letsencrypt
Incident Report for Vercel
Resolved
This incident has been resolved.
Posted May 19, 2024 - 14:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2024 - 23:22 UTC
Identified
Our SSL Certificate provider Letsencrypt is facing a disruption. You can find more details here: https://letsencrypt.status.io/pages/incident/55957a99e800baa4470002da/66492ffd0aea6605a975e43d.
Posted May 18, 2024 - 23:12 UTC
This incident affected: SSL Certificates.