Elevated request latency and errors

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 16:57 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 11, 2025 - 16:42 UTC

Monitoring

This issue occurred between 16:20 — 16:26 UTC and has already been resolved. We are monitoring our fixes to ensure the issue doesn't return.
Posted Mar 11, 2025 - 16:34 UTC
This incident affected: Edge Network (CDG1 - Paris, France, Europe).