Failures to load data across multiple services on the Vercel dashboard, API, and CLI

Incident Report for Vercel

Resolved

All services remain operational. New data is being processed as expected. The majority of the backfill is complete and a long tail of data will be processed within the next couple of hours.
Posted May 06, 2026 - 00:38 UTC

Update

All systems are operational. We are continuing to monitor the backfill process, which is expected to take a couple of hours. New data is being processed as expected.
Posted May 05, 2026 - 17:14 UTC

Update

We are continuing to monitor for any further issues.
Posted May 05, 2026 - 17:12 UTC

Monitoring

Impacted services have recovered. We are continuing to monitoring, while backfilling remaining missing data.
Posted May 05, 2026 - 16:50 UTC

Update

Reading data from impacted services has recovered. We are working to backfill any missing data in Observability.
Posted May 05, 2026 - 16:37 UTC

Update

We are seeing services start to recover as we incrementally apply the fix.
Posted May 05, 2026 - 16:30 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 05, 2026 - 15:58 UTC

Identified

We've identified an issue where various services in the Vercel dashboard, API, and CLI are failing to load data. These services include Observability, Speed Insights, Alerts, Usage, Web Analytics, Firewall, and CDN observability. Broadly, areas backed by analytical data are affected.

We have identified the issue and are working on a fix.

Production applications running on Vercel are not impacted.
Posted May 05, 2026 - 15:15 UTC
This incident affected: Dashboard (Dashboard) and API, Speed Insights, Web Analytics, Observability.