Elevated Connection Latency in dub1 (Dublin, Ireland) Edge Region

Incident Report for Vercel

Resolved

This incident has been resolved, and traffic has been fully routed back to the dub1 region.
Posted Jan 28, 2026 - 20:21 UTC

Monitoring

A fix has been implemented and we have routed traffic back to dub1. We are actively monitoring the results.
Posted Jan 28, 2026 - 19:56 UTC

Update

We have rerouted all dub1 Edge region traffic as of 17:15 UTC, and traffic should no longer see increased latency. We are continuing to work on a fix to restore traffic back to dub1.
Posted Jan 28, 2026 - 18:27 UTC

Update

The dub1 Edge traffic is currently being rerouted to the nearest Edge region (lhr1) to mitigate the impact. We are continuing to work on a fix for this issue.
Posted Jan 28, 2026 - 17:43 UTC

Identified

We have identified elevated connection latency and intermittent timeouts affecting serving traffic in the dub1 Edge region. A fix is currently being rolled out.
Posted Jan 28, 2026 - 17:19 UTC
This incident affected: Edge Network (DUB1 - Dublin, Ireland).