Builds logs stuck in loading state in iad1

Incident Report for Vercel

Resolved

The incident has been resolved. If you don't see build logs for a specific deployment, please redeploy.
Posted Apr 07, 2026 - 08:37 UTC

Monitoring

We identified the cause of build logs stuck in the loading state affecting iad1 and are working around the issue for new builds. Please redeploy to your build to view build logs.
Posted Apr 07, 2026 - 08:29 UTC

Investigating

We are investigating reports of build logs stuck in loading state.
Posted Apr 07, 2026 - 07:19 UTC
This incident affected: Build & Deploy (Builds) and Logs.