Deployment Creation Errors from GitLab commits

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 15:05 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 21, 2025 - 14:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2025 - 13:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 21, 2025 - 12:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 21, 2025 - 12:03 UTC

Investigating

We are currently investigating elevated error reports of deployment creation for commits from GitLab. Existing deployments and live traffic are not affected by this issue. We will share updates as they become available.

Updates from GitLab are available here: https://status.gitlab.com/pages/incident/5b36dc6502d06804c08349f7/68a704148b984405a33ebd51
Posted Aug 21, 2025 - 11:24 UTC
This incident affected: Build & Deploy (Builds).