Delays Loading Observability, Analytics and Speed Insights

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Apr 19, 2026 - 21:39 UTC

Monitoring

A fix has been implemented and we are seeing recovery. No action is required - data may continue to be partially delayed as it is backfilled.
Posted Apr 19, 2026 - 21:22 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 19, 2026 - 21:12 UTC

Investigating

We are currently experiencing delays in loading Observability, Analytics and Speed Insights data on the dashboard. This may also affect User Activity Events and Firewall UI. Vercel Alerts may also be delayed. We will provide additional updates as they become available.
Posted Apr 19, 2026 - 20:43 UTC
This incident affected: Dashboard (Dashboard) and Logs, Speed Insights, Web Analytics.