Errors accessing teams that require 2FA

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 23:34 UTC

Monitoring

A fix has been implemented and services have recovered. We are continuing to monitor to ensure that the services remain stable. We will provide additional updates as they become available.
Posted Jul 15, 2026 - 23:16 UTC

Identified

We have identified an increase in erroneous 2FA (two-factor authentication) challenges and errors when accessing the Vercel dashboard and multiple API services for teams that require 2FA. We will share more information once we have it.
Posted Jul 15, 2026 - 23:04 UTC
This incident affected: Dashboard (Dashboard) and AI Gateway, API.