Errors creating Support Center cases

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 15:34 UTC

Monitoring

We've identified the issue, and we are working on a fix. Vercel customers should be able to create cases normally while we monitor case operation metrics closely.
Posted Dec 12, 2025 - 14:45 UTC

Investigating

We are investigating an issue with creating new Support Center cases.

For affected Enterprise customers, please escalate out to Vercel contacts via Slack or email for support. For Pro and Hobby customers, please use the Vercel Community: https://community.vercel.com/
Posted Dec 12, 2025 - 13:12 UTC