Vercel Dashboard Errors

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 03:37 UTC

Investigating

We are currently investigating intermittent issues when viewing deployments and projects on the Vercel Dashboard.
Posted Jun 05, 2025 - 00:00 UTC
This incident affected: Dashboard (Dashboard).