Elevated Dashboard Errors on Usage page

Incident Report for Vercel

Resolved

This incident has been resolved.
Posted May 29, 2023 - 18:46 UTC

Update

We are continuing to monitor for any further issues.
Posted May 29, 2023 - 18:26 UTC

Monitoring

A fix has been implemented and we are monitoring results.
Posted May 29, 2023 - 18:23 UTC

Investigating

We are currently investigating reports of elevated error rates on the Usage page of the Vercel Dashboard. Existing deployments and live traffic are not affected by this issue. We will share updates as they become available.
Posted May 29, 2023 - 16:46 UTC
This incident affected: Dashboard (Dashboard).