Elevated INTERNAL_EDGE_FUNCTION_INVOCATION_FAILED errors
Incident Report for Vercel
Resolved
This incident has been resolved.

The cause of this incident was different from the last incident that happened on 2024-07-10: https://www.vercel-status.com/incidents/d960v5739qdb

Unlike the last incident, the issue did not impact new deployments. Customers may have seen a small amount of INTERNAL_EDGE_FUNCTION_INVOCATION_FAILED errors on existing deployments during the following windows:

- 2024-07-17 14:30 ~ 2024-07-17 15:40 UTC
- 2024-07-17 19:46 ~ 2024-07-17 22:50 UTC

The issue was resolved by reverting a recent bad release.
Posted Jul 18, 2024 - 00:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 23:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 17, 2024 - 22:14 UTC
Investigating
Edge Functions & Edge Middleware are degraded, and may return INTERNAL_EDGE_FUNCTION_INVOCATION_FAILED error. We are actively investigating this and will provide updates as they become available.
Posted Jul 17, 2024 - 20:11 UTC
This incident affected: Edge Functions and Edge Middleware.