Increased error rate when creating Edge Functions

Incident Report for Vercel

Resolved

This incident has been resolved. We are continuing to investigate Edge Config delays separately. For updates on that issue, subscribe here: https://www.vercel-status.com/incidents/2258cblmqhkd
Posted Nov 03, 2023 - 04:34 UTC

Update

New deployments are building and operational. Edge Functions are still experiencing delays. We will continue to monitor and provide further updates.
Posted Nov 03, 2023 - 02:18 UTC

Monitoring

A fix has been implemented by our upstream provider and we’re continuing to monitor the results.
Posted Nov 03, 2023 - 01:02 UTC

Update

We are continuing to closely monitor the situation with our upstream provider. We are seeing preliminary recovery and will provide further updates as soon as possible.
Posted Nov 03, 2023 - 00:15 UTC

Update

We're still actively monitoring the situation with our upstream provider and will provide updates as soon as possible.
Posted Nov 02, 2023 - 20:47 UTC

Update

We are continuing to work with our upstream providers towards a mitigation.
Posted Nov 02, 2023 - 18:17 UTC

Update

We are continuing to work with our upstream providers towards a mitigation.
Posted Nov 02, 2023 - 15:58 UTC

Identified

We identified the root cause as an issue with one of our upstream providers and working with them towards mitigation.
Posted Nov 02, 2023 - 12:27 UTC

Investigating

We are currently investigating elevated errors when creating Edge Functions, new Blob stores, and for propagation for Edge Config updates. We are working with our upstream provider to resolve this. We will provide updates as soon as they become available.
Posted Nov 02, 2023 - 12:17 UTC
This incident affected: Build & Deploy (Builds) and Storage (Blob, Edge Config).